STATUS=ERROR when testing scripts in Zencart Import/Export Setup
Question asked by Claude Blais - 9/18/2019 at 11:45 AM
Answered
We have just upgraded to the latest version of Zencart and are now testing the Export of our inventory.
FTP connection is working fine.  When running the Test Scripts, getting an STATUS=ERROR.
 
 
 

9 Replies

Reply to Thread
0
Terry Swiers Replied
Employee Post
There are a couple of things that you can check first.  If you are using a secure connection to the site, check the certificate information to make sure that there isn't a name mismatch between the domain and the certificate.  The older version of the utility won't allow for a name mismatch, so it will simply fail.

Secondly, if you upgraded your PHP version as well, it's possible that the newer version of the PHP precompiler is configured to use the newer mySQLi connector rather than the older one.  The older version of our utility doesn't have any clue about how to use the newer mysqli connector.

Let us know what you find with regards to these two issues and then we'll look at a path forward.
 
0
Claude Blais Replied
I passed the suggestion above to my Web Integration Consultant, and he provided the following.  And yes we upgraded the PHP version as well.  Hyperlinks are provided to show more information, but I can't paste them in this reply.
 
SSL seems fine.   
 
This install is using PHP 7.2   When I look at the php info ) I see  php72/root/etc/php.d/20-zip.ini, /opt/cpanel/ea-php72/root/etc/php.d/30-mysqli.ini, /opt/cpanel/ea- 
 
so, might mean an upgrade to the software is needed ?? 
 
0
Claude Blais Replied
Further information to possibly help.  In the php.error log on the server, we get the following:
 
[18-Sep-2019 20:35:04 UTC] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; db has a deprecated constructor in /home/wfwmbsales/public_html/atrex/commondb.php on line 62
[18-Sep-2019 20:35:04 UTC] PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; query has a deprecated constructor in /home/wfwmbsales/public_html/atrex/commondb.php on line 167
[18-Sep-2019 20:35:04 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /home/wfwmbsales/public_html/atrex/commondb.php:108
Stack trace:
#0 /home/wfwmbsales/public_html/atrex/commondb.php(82): db->connect()
#1 /home/wfwmbsales/public_html/atrex/orders.php(229) : eval()'d code(410): db->db('localhost', 'wfwmbsales_wfwm...', 'tkmu,#4DC@#?')
#2 /home/wfwmbsales/public_html/atrex/orders.php(229): eval()
#3 {main}
  thrown in /home/wfwmbsales/public_html/atrex/commondb.php on line 108
0
Terry Swiers Replied
Employee Post
From what you sent back regarding the mysqli and the update to the PHP version, upgrading your Atrex and the Zen Cart utility would be the first step.  The latest version of the Zen Cart utility has been reworked for most, if not all of the deprecated PHP function calls.  It will also switch automatically between the mysql and mysqli PHP extensions depending on which one you have enabled.

If you have your client center login information, you can log into our client center (https://www.1000years.com/ClientCenter/login.aspx) and initiate the upgrade process from there.  If you don't have your login information, shoot an email to sales@atrex.com with the company name or serial number that you are registered under and we'll get you the login information.
0
Claude Blais Replied
We currently have the Zencart 1.5.6c version just installed on the server.  I have the eCommerce Import/Export Zencart 1.3x/1,5x on the desktop.  We have Atrex 15.52.  As far as I can see, we have the latest version of the Zencart server/desktop software.
 
0
Terry Swiers Replied
Employee Post
If you are running Atrex 15.x, then you most definitely do not have the latest version of the Zen Cart utility.  You might have the latest version compatible with Atrex 15, but that's not what you need to handle PHP 7.  

You will need to get up to Atrex 18 or 19 along with version 7 of the Import utility which is what is currently available from our web site.
 
0
Claude Blais Replied
Ok, so to resume to confirm I understand all of this.  We currently need to go to PHP 7 on the server as requested by our Web Hosting provider.  So to do this, we need latest version of Zen Cart, i.e. v1.5.6c.
 
We are currently licenced for Atrex 15, which is supported by the eCommerce/Zen Cart Utility v 4.0.0.36.
 
eCommerce/Zen Cart Utility v 4.0.0.36 is not compatible with Zen Cart v1.5.6c and there is absolutely no way to make it work together?
 
If not, we therefore need eCommerce/Zen Cart Utility v 7, which in turn does not work with Atrex 15, which means that we need to upgrade to a higher version of Atrex?
 
Thanks for providing this information.
 
0
Claude Blais Replied
I have put in a ticket to get more information and confirmation of all the versions required to make this work.
Considering this thread close for now.
 
Thanks.
0
Terry Swiers Replied
Employee Post Marked As Answer
I'm going to respond, just so anyone else who runs into this issue can get the answer to the questions without having to do additional searching. In short, there are two issues. The first is that the older version of the import utilities make use of the deprecated mysql PHP extension. Enabling the old mysql extension should allow the utility to connect to the database as long as this is the only reason for the connection failure. The second issue is the PHP version. PHP 7 was released after the last builds we made for the v15 compatible Zen Cart utility. As such, the scripts for that version assumed the presence of either PHP 4 or 5 and makes use of some functions that are either deprecated or removed from PHP 7. So, even if you do get the database connection, it is possible there may be other places in the old scripts that fail when attempting to run under PHP 7. The current version of the utility (version 7) is compatible with both PHP 5 and 7.

Reply to Thread